Lines Matching refs:arg
51 arg: const rs_matrix4x4* viewProj, "Matrix to extract planes from."
52 arg: float4* left, "Left plane."
53 arg: float4* right, "Right plane."
54 arg: float4* top, "Top plane."
55 arg: float4* bottom, "Bottom plane."
56 arg: float4* near, "Near plane."
57 arg: float4* far, "Far plane."
112 arg: const rs_matrix4x4* viewProj
113 arg: float4* left
114 arg: float4* righ
115 arg: float4* top
116 arg: float4* bottom
117 arg: float4* near
118 arg: float4* far
126 arg: float4* sphere, "float4 representing the sphere."
127 arg: float4* left, "Left plane."
128 arg: float4* right, "Right plane."
129 arg: float4* top, "Top plane."
130 arg: float4* bottom, "Bottom plane."
131 arg: float4* near, "Near plane."
132 arg: float4* far, "Far plane."
169 arg: float4* sphere
170 arg: float4* left
171 arg: float4* right
172 arg: float4* top
173 arg: float4* bottom
174 arg: float4* near
175 arg: float4* far
182 arg: const #1* m, "Matrix to extract the element from."
183 arg: uint32_t col, "Zero-based column of the element to be extracted."
184 arg: uint32_t row, "Zero-based row of the element to extracted."
195 arg: rs_matrix4x4* m, "Matrix to invert."
204 arg: rs_matrix4x4* m, "Matrix to modify."
215 arg: #1* destination, "Matrix to set."
216 arg: const float* array, "Array of values to set the matrix to. These arrays should be 4, 9, or 16 …
240 arg: #1* destination
241 arg: const #1* source, "Source matrix."
248 arg: rs_matrix4x4* destination
249 arg: const #1* source
255 arg: rs_matrix4x4* m, "Matrix to set."
256 arg: float left
257 arg: float right
258 arg: float bottom
259 arg: float top
260 arg: float near
261 arg: float far
275 arg: #1* m, "Matrix to set."
285 arg: #1* m, "Matrix to set."
286 arg: const #1* lhs, "Left matrix of the product."
287 arg: const #1* rhs, "Right matrix of the product."
305 arg: rs_matrix4x4* m, "Matrix to set."
306 arg: float left
307 arg: float right
308 arg: float bottom
309 arg: float top
310 arg: float near
311 arg: float far
327 arg: rs_matrix4x4* m, "Matrix to set."
328 arg: float fovy, "Field of view, in degrees along the Y axis."
329 arg: float aspect, "Ratio of x / y."
330 arg: float near, "Near clipping plane."
331 arg: float far, "Far clipping plane."
343 arg: rs_matrix4x4* m, "Matrix to set."
344 arg: float rot, "How much rotation to do, in degrees."
345 arg: float x, "X component of the vector that is the axis of rotation."
346 arg: float y, "Y component of the vector that is the axis of rotation."
347 arg: float z, "Z component of the vector that is the axis of rotation."
360 arg: rs_matrix4x4* m, "Matrix to set."
361 arg: float x, "Multiple to scale the x components by."
362 arg: float y, "Multiple to scale the y components by."
363 arg: float z, "Multiple to scale the z components by."
375 arg: rs_matrix4x4* m, "Matrix to set."
376 arg: float x, "Number to add to each x component."
377 arg: float y, "Number to add to each y component."
378 arg: float z, "Number to add to each z component."
392 arg: #1* m, "Left matrix of the product and the matrix to be set."
393 arg: const #1* rhs, "Right matrix of the product."
418 arg: rs_matrix4x4* m
419 arg: float4 in
426 arg: rs_matrix4x4* m
427 arg: float3 in
434 arg: rs_matrix4x4* m
435 arg: float2 in
442 arg: rs_matrix3x3* m
443 arg: float3 in
450 arg: rs_matrix3x3* m
451 arg: float2 in
458 arg: rs_matrix2x2* m
459 arg: float2 in
466 arg: const rs_matrix4x4* m
467 arg: float4 in
474 arg: const rs_matrix4x4* m
475 arg: float3 in
482 arg: const rs_matrix4x4* m
483 arg: float2 in
490 arg: const rs_matrix3x3* m
491 arg: float3 in
498 arg: const rs_matrix3x3* m
499 arg: float2 in
506 arg: const rs_matrix2x2* m
507 arg: float2 in
513 arg: rs_matrix4x4* m, "Matrix to modify."
514 arg: float rot, "How much rotation to do, in degrees."
515 arg: float x, "X component of the vector that is the axis of rotation."
516 arg: float y, "Y component of the vector that is the axis of rotation."
517 arg: float z, "Z component of the vector that is the axis of rotation."
532 arg: rs_matrix4x4* m, "Matrix to modify."
533 arg: float x, "Multiple to scale the x components by."
534 arg: float y, "Multiple to scale the y components by."
535 arg: float z, "Multiple to scale the z components by."
551 arg: #1* m, "Matrix that will be modified."
552 arg: uint32_t col, "Zero-based column of the element to be set."
553 arg: uint32_t row, "Zero-based row of the element to be set."
554 arg: float v, "Value to set."
565 arg: rs_matrix4x4* m, "Matrix to modify."
566 arg: float x, "Number to add to each x component."
567 arg: float y, "Number to add to each y component."
568 arg: float z, "Number to add to each z component."
584 arg: #1 m, "Matrix to transpose."